PHP-versjoner

Har nå funnet ut av mysteriet med PHP-versjoner som dukket opp i gruppetimen i dag.

Jeg hadde installert PHP versjon 7.2 på samtlige webservevere i dag tidlig.

Du kan sjekke hvilken versjon av PHP som kjører på din egen webserver ved å logge på som administrator og deretter navigere til Reports » Status report og se på statusen for PHP. Den skal være 7.2.10 (er den noe annet så gi meg beskjed).

Men men i CLIet får man den versjonen som RHEL7 har som standard (5.4.16) med mindre man endrer brukerprofilen sin i CLIet til å velge en annen versjon av PHP. Jeg hadde endret min egen profil – men ikke deres. Dermed var det bare jeg som fikk den omtalte feilmeldingen fra drush.

I og med at drush fungerer bedre med PHP 5.4.16 enn med PHP 7.2.10 lar jeg være å oppgradere PHP i CLIet (inntil drush blir oppgradert til å ikke gi feil med denne versjonen av PHP).